Invintus Status
Resolved

Player And Listing Degraded

Mar 13, 2026, 3:40 PM PDT · 1 hr 50 min

Affected services

Control CenterPlayer

Overview

We are currently investigating issues with Channel Listings and Player loads. This appears to be a third party realtime-updates provider. We are making attempts to confirm and apply mitigation plans discussed and developed earlier this week. Active Live Streams, Archives, or any internal streaming systems are unaffected.

Updates

Resolved

All mitigations are in place: page loads and background updates for the Control Center, Channel Listings, and Video Player are working. We do see continued error rates with the third-party's service but are marking this degradation as resolved.

Update

Our video player has been updated to help mitigate the connection issues. We're monitoring the performance of load times and are seeing better time-to-load pages and improved video Playback. Realtime updates to the Control Center may continue to be affected.

Update

Updates to the Channel Listings has been released and we're monitoring how it's performing.